Help

Versions

Requires HomeSeer HS3 version 3.0.0.97 or later.

For mobile access on Android, HSTouch Android client 1.0.0.75 or later required.

For IOS HSTouch access, downoad the latest from the iTunes Store.

For Windows HSTouch access, select myHomeSeer as an option for connection.

Notes

Earthlink email users require manual verification. If you do not recieve a verification email, please send an inquiry to sales@homeseer.com for assistance.

We have updated the server and this update requires an updated version of HS3. If you are using the released version 3.0.0.96, please update to 3.0.0.97. Restart HS3 to get prompted for the update, or see below. If you are using a version later than 3.0.0.97, please get the latest beta from below.

If you are using a HomeTroller SEL or Zee, click "Check for Updates" in setup and update to version 3.0.0.143 or later.

Links

User Guide

Download HS3 3.0.0.97

Latest Beta